Join the Meeting Place for Moms!
Talk to other moms, share advice, and have fun!

(minimum 6 characters)

Kind of strange, but let me know what you think

+ preggo test on 18th of feb. last period was the 20th of jan. I ovulated the 5th or 6th of feb (I know bc I had a HCG shot to trigger ovulation). IUI done on the 6th of feb. I had blood work on the 23rd & 25th of feb. still + for pregnancy & HCG levels are still going up. I do NOT have ANY preggo symptoms!! Its wierd bc based on my last period I should be about 6wds 5days. Based on my O time I should be less than that. I had a sono done (slight cramping with brown spotting) on the 2nd of March (which would have put me right around the 6 week mark) ER doc said that they did NOT see anything! NOTHING in my uterus or my tubes. Strange, but I have an appointment with my OB on the 23rd (thats the earliest she can see me) but I wanted to know if anyone else did not have any preggo symptoms and were really preggo? I mean I am tiard more and off and on my nipples are sore and tender, but thats it. Any help????

Answer Question
 
Anonymous

Asked by Anonymous at 9:32 AM on Mar. 7, 2009 in Pregnancy

Answers (2)
  • It is absolutely normal to not feel anything at all. Fatigue is a symptom. Or, do you really wish to be puking your guts out with morning sickness?
    halfpint_ny

    Answer by halfpint_ny at 9:51 AM on Mar. 7, 2009

  • I didn't have any symptoms w/ my son at all. This pregnancy totally the opposite! Each one is different!
    Tiffany237

    Answer by Tiffany237 at 11:24 AM on Mar. 7, 2009

Join CafeMom now to contribute your answer and become part of our community. It's free and takes just a minute.
close Cafemom Join now to connect to other members! Connect with Facebook or Sign Up Using Email

Already Joined? LOG IN