Join the Meeting Place for Moms!
Talk to other moms, share advice, and have fun!

(minimum 6 characters)

confused

ok....the health department told me i had a bacterial infection down there after doing a pap smear.i went cause i have had lots of pain.my side hurt where ovarires are,certain postions in sex really brought pain.i just always had pain and abnormal period.well i was not fully off my period i was still spotting when they did my pap smear.Is it possible the bacteria she found was cause of my period?Cause whole point of cycle is to get rid of bacteria.I have had cysts bust before but she said no cysts....but never did ultrasound.

Answer Question
 
Anonymous

Asked by Anonymous at 1:11 PM on Mar. 25, 2009 in Health

Answers (9)
  • Did they do a blood test?
    kemclaughlin

    Answer by kemclaughlin at 1:13 PM on Mar. 25, 2009

  • First of all, you went when you were spotting? You should always wait until a week after your period because the results could show abnormalities. Please call them again and see if you can go in for further testing and also a new pap. Good luck!!!!
    Tayandstevenmom

    Answer by Tayandstevenmom at 1:16 PM on Mar. 25, 2009

  • no no blood test no ultra sound nothing!She said thats what it was that i had no cysts.Im still in pain its been about a month in a half.I have no insurance so i can only go there.but im wondering if the bacteria she found was from my period i wasnt fully off.
    Anonymous

    Answer by Anonymous at 1:18 PM on Mar. 25, 2009

  • Most def. I would have a retest
    bizima4

    Answer by bizima4 at 1:18 PM on Mar. 25, 2009

  • i was going also to get birth control so i still went i told them i was still spotting and she said it won't make any difference.
    Anonymous

    Answer by Anonymous at 1:19 PM on Mar. 25, 2009

  • It could have been if you were using tampons, but an infection could explain the pain as well as the cysts. I would ask for further testing too. What did they do to treat the infection?
    kemclaughlin

    Answer by kemclaughlin at 1:19 PM on Mar. 25, 2009

  • she gave me anitibotics.i have had cysts before one even busted,i know that for sure cause i was at hospital visting my mom at time and they rushed me to er cause didn't know what was wrong.that and cysts run in my family.they wont do ultrasounds at health department.
    Anonymous

    Answer by Anonymous at 1:22 PM on Mar. 25, 2009

  • demand a re check!! ( completeley off the period) have that ultra sound done and blood tests, !!!!!
    ashleyamanda

    Answer by ashleyamanda at 1:32 PM on Mar. 25, 2009

  • If she gave you antibiotics and the symptoms aren't gone, demand further testing.
    kemclaughlin

    Answer by kemclaughlin at 7:12 PM on Mar. 25, 2009

Join CafeMom now to contribute your answer and become part of our community. It's free and takes just a minute.