Join the Meeting Place for Moms!
Talk to other moms, share advice, and have fun!

(minimum 6 characters)

blood in urine after c section

I was in labor for 12hrs and she came almost all the way down but I couldn't dilate past 9cms...I don't see blood in the toilet but on my pad its definitely leaking out a little from the front. Think this is a UTI??

Answer Question
 
stepmom929

Asked by stepmom929 at 1:44 AM on May. 28, 2009 in Babies (0-12 months)

Level 12 (920 Credits)
Answers (5)
  • From the way you worded that it sounds like your pad wasn't in the right place.
    Anonymous

    Answer by Anonymous at 1:47 AM on May. 28, 2009

  • if you're sure it's coming out where the urine comes out, could be kidney stones....or it may be your period.
    GreekMama28

    Answer by GreekMama28 at 1:47 AM on May. 28, 2009

  • i agree with the first poster.. no urine in pee but there is on the pad but not where it should be.. just sounds like you didnt place it right lol
    Anonymous

    Answer by Anonymous at 1:48 AM on May. 28, 2009

  • I actually learned today that bladder infections are very common after a section, i myself have one ...so its possible. call your ob if you think thats it. :o)
    Bearsjen

    Answer by Bearsjen at 2:17 AM on May. 28, 2009

  • most likely it isnt. rememer all our stuff is close together so sometimes it is hard to tell. now if there is pain involved when you urinate, even a little you can get that checked via catheter so they can be certain if the blood is in the urine or not. i agree with all the moms here though. when i recovered from my c section i seemed to be bleeding from everywhere! lol oh and congrats on getting to 9cm. i was fully effaced and at 5cm after 14 grueling hours. my poor baby had cone head. lol he loves hearing that.
    Anjo.Solene

    Answer by Anjo.Solene at 8:07 AM on May. 28, 2009

Join CafeMom now to contribute your answer and become part of our community. It's free and takes just a minute.