Join the Meeting Place for Moms!
Talk to other moms, share advice, and have fun!

(minimum 6 characters)

hey..

okay, so i had a yeast infection about two three weeks ago, i took all my meds and i used all the stuff i had too, and the itchy is now gone, and well we havent had sex until last night, but IT BURNS AND HURTS specially when its over, and i have to go pee.. it burns so much!!! is that normal?

 
Anonymous

Asked by Anonymous at 12:39 PM on Jun. 26, 2009 in Health

This question is closed.
Answers (5)
  • This could be something that is easily figured out by a call to your doc. Just call the office and say you have a question for your doctor, they should call you back within an hour. Just make sure you call first thing in the morning.

    Farrahann

    Answer by Farrahann at 12:43 PM on Jun. 26, 2009

  • doesnt sound like it went away or you got it back or something.
    Anonymous

    Answer by Anonymous at 12:39 PM on Jun. 26, 2009

  • Sounds a little more serous, maybe you are too dry now?
    jenree33

    Answer by jenree33 at 12:40 PM on Jun. 26, 2009

  • No doesn't sound normal if you treated it 3 weeks ago.... I would get checked it may be a different kind of infection.
    Anonymous

    Answer by Anonymous at 12:40 PM on Jun. 26, 2009

  • Didn't realize how early in the day it is...lol. I got up real early. Just call now...they'll get back to you after lunch.
    Farrahann

    Answer by Farrahann at 12:45 PM on Jun. 26, 2009

Next question in Health
TASTE BUDS

Next question overall (Pets)
How do you stop a dogs diarrhea ?

close Cafemom Join now to connect to other members! Connect with Facebook or Sign Up Using Email

Already Joined? LOG IN