Join the Meeting Place for Moms!
Talk to other moms, share advice, and have fun!

(minimum 6 characters)

Question.....

about a week ago i had some browen discharge for about three days only on the tp. So i havnt had anymore brown discharge. i was at work and had to pee...so i went to the bathroom and took care of my buisness. When i got up the toilet was full of bloody pee...i was like great she's here. it's been two almost three days and I still have not seen even the faintest hint of any blood anywhere!!!!! know i am really confused!!!! any one have these symptoms???

Answer Question
 
SamiS7

Asked by SamiS7 at 1:17 PM on Aug. 17, 2009 in Trying to Conceive

Level 1 (0 Credits)
Answers (3)
  • It could be implantation bleeding, or it could just be a very light period.
    I know OB's are a little weary when it gets to be bright red like that.
    Take a HPT........
    K_Sawyer

    Answer by K_Sawyer at 1:22 PM on Aug. 17, 2009

  • it sounds like you are pregnant or you might have miscarryed i would take a pregancy test 2 weeks after you have had sex and make sure or you can go to the doctor and they will do a blood test to know right away good luck
    darkangel198656

    Answer by darkangel198656 at 1:23 PM on Aug. 17, 2009

  • Thanks you guys. do you realy think i miscarried??? I havnt had any real bad cramping or anything.The only time i saw bright red blood was in the toilet. The brown discharge wasn't much either. I really appreciate your help.
    SamiS7

    Answer by SamiS7 at 2:27 PM on Aug. 17, 2009

Join CafeMom now to contribute your answer and become part of our community. It's free and takes just a minute.
close Join now to connect to
other members!
Connect with Facebook or Sign Up Using Email

Already Joined? LOG IN