Join the Meeting Place for Moms!
Talk to other moms, share advice, and have fun!

(minimum 6 characters)

Had my membranes stripped today...

I had my membranes stripped today and I've lost my mucus plug 3x now (including once today when my midwife stripped my membranes). My midwife told me I would have some cramping and maybe some spotting. Well it's been a few hours and I just noticed that I was bleeding. It's definitely more than spotting, but I don't know if it would be enough to fill a pad. It does look like period blood though, including clots. It's bright red. I bled through my sweatpants. I am 40w+2d

I was just wondering if that was normal after having this procedure done.

 
Tashwitz

Asked by Tashwitz at 2:47 PM on Oct. 27, 2009 in Pregnancy

Level 1 (0 Credits)
This question is closed.
Answers (2)
  • When I had mine done my doc said if it works it will be within 3 days. he was right and i thought I was going to die the first 2. I also had 3 mucus plugs with that one, If it doesnt stop in a few hours I would call for sure, in the meantime drink lots of water . If you are always concerned that is what they are there for is to help you!
    canthaveboys1

    Answer by canthaveboys1 at 2:50 PM on Oct. 27, 2009

  • I did that too. I don't know if it's normal or not, but I just didn't worry about it lol. Maybe I should have. Call your midwife and ask.
    Ati_13

    Answer by Ati_13 at 2:49 PM on Oct. 27, 2009

close Join now to connect to
other members!
Connect with Facebook or Sign Up Using Email

Already Joined? LOG IN