Join the Meeting Place for Moms!
Talk to other moms, share advice, and have fun!

(minimum 6 characters)

Does your mucous plug have to have blood in it?

I'm 40 weeks today and i havent lost my plug yet, the other day i went pee (sorry tmi) and i wiped and it wasnt mucousy it was just really really light pink it happend 2 times that night and nothing since then..Well i went to the bathroom today and when i wiped it was clear and really snoty almost like i blew my nose on the tissue..Could it be my plug??

Answer Question
 
XandersMaMa118

Asked by XandersMaMa118 at 4:32 PM on Nov. 9, 2009 in Pregnancy

Level 1 (0 Credits)
Answers (5)
  • Sounds like your plug to me. You can read my birth story. It tells when i lost my plug and when labor started.

    At first I just had some funky discharge. I thought I was getting a yeast infection. Later that day it progressed into stringy snot looking stuff.
    hopinforanother

    Answer by hopinforanother at 4:37 PM on Nov. 9, 2009

  • Thats what my plug looked like, clear, thick and snotty looking but no blood. I went into labor 2 days later. Good luck and congrats!
    Anonymous

    Answer by Anonymous at 4:39 PM on Nov. 9, 2009

  • Alright thanks guys!!
    XandersMaMa118

    Answer by XandersMaMa118 at 4:54 PM on Nov. 9, 2009

  • my plug didn't have blood in it. it was kind of yellowy/snotty. :) i went into labor 3-4 days later but it's hard to say when it will happen based on losing the mucus plug. but you are getting closer!
    Stefanie83

    Answer by Stefanie83 at 4:57 PM on Nov. 9, 2009

  • I lost mine 2 weeks before delivery, it had no blood either.... it was white and clumpy and came out in small pieces.
    xDoomsDayAngelx

    Answer by xDoomsDayAngelx at 3:30 PM on Nov. 12, 2009

Join CafeMom now to contribute your answer and become part of our community. It's free and takes just a minute.
close Join now to connect to
other members!
Connect with Facebook or Sign Up Using Email

Already Joined? LOG IN