Join the Meeting Place for Moms!
Talk to other moms, share advice, and have fun!

(minimum 6 characters)

I had a tubal, I'm not pregnant, I took a test, somethings wrong?

I had my period two weeks ago. I have had this gnawing cramping feeling for a week, now I'm sitting down and it's really painful. Sorry if it's TMI but I'm also having bloody chunks of mucos coming out of me. It just seems strange. I had a tubal ligation, and no I am not pregnant. What in the world could this be?

Answer Question
 
Anonymous

Asked by Anonymous at 8:55 PM on Jan. 22, 2010 in Health

Answers (6)
  • Call your doctor..Maybe an infection?
    ali_1107

    Answer by ali_1107 at 8:58 PM on Jan. 22, 2010

  •  Oh Definitely call your Doctor. I had a tubal and NOTHING like that happend to me. Best of luck.

    jblueeyes228

    Answer by jblueeyes228 at 9:01 PM on Jan. 22, 2010

  • sorry, I should be more specific, my tubal was done a year ago.
    Anonymous

    Answer by Anonymous at 9:06 PM on Jan. 22, 2010

  • I realize you said that you're not pregnant, but that sounds like the symptoms of a miscarriage :(
    mire621

    Answer by mire621 at 9:08 PM on Jan. 22, 2010

  • I would see your doctor as soon as you can I had my tubal over 3 yrs ago and that has never happened to me
    mom2ryneandsam

    Answer by mom2ryneandsam at 9:35 PM on Jan. 22, 2010

  • Yes, please get medical care!! I hope its not too painful! But go in asap. My friend had 2 sons after her tubes tied!! Rare I'm sure!!
    Angellinda

    Answer by Angellinda at 9:47 PM on Jan. 22, 2010

Join CafeMom now to contribute your answer and become part of our community. It's free and takes just a minute.
close Join now to connect to
other members!
Connect with Facebook or Sign Up Using Email

Already Joined? LOG IN