Join the Meeting Place for Moms!
Talk to other moms, share advice, and have fun!

(minimum 6 characters)

Am I having implantation bleeding?

I got my period on the 21st (3 days early). It was heavy, basically like a normal period. It lasted until the 26th (5 day periods have always been normal for me). Today (the 30th) I noticed light pink bleeding that is only there when i wipe. I have 3 children but i know i've never experienced implantation. There is also a bit of cramping. Nothing painful and not a period type of cramp. Just discomfort really. Any ideas?

Answer Question
 
stampmama

Asked by stampmama at 4:43 PM on Jun. 30, 2010 in Pregnancy

Level 5 (63 Credits)
Answers (2)
  • You haven't ovulated yet so it's not implantation. Even if you had, it would take a couple days from conception for it to implant...you would need about 4 more days to ovulate
    Jademom07

    Answer by Jademom07 at 4:49 PM on Jun. 30, 2010

  • I actually have ovulated already. I know that sounds weird but I dont ovulate 'normal'. Lol. The reason I know i've ovulated is because i had the clear discharge and thats when i decided to use one of those ovulation thingies and it was positive but in the same token, it could've been false too. I'm not TTC or anything but i'm not preventing it either. Just curious if anyone might know what's possibly goin on.
    stampmama

    Comment by stampmama (original poster) at 4:52 PM on Jun. 30, 2010

Join CafeMom now to contribute your answer and become part of our community. It's free and takes just a minute.
close Cafemom Join now to connect to other members! Connect with Facebook or Sign Up Using Email

Already Joined? LOG IN