Join the Meeting Place for Moms!
Talk to other moms, share advice, and have fun!

(minimum 6 characters)

1 Bump

Has anyone ever had a bladder infection but didn't have the pulling/burning pain?

I only had pain in the bladder area all day and night but didn't hurt when I used the bathroom. I also used the bathroom a lot more than normal. I am post partum so doctor talked to me over the phone and guessed it must be a bladder infection or maybe uterine infection. I started taking the antibotics on Wednesday and feel much better. I have had a few UTI's in my day and they have always burned/pulled as u use the bathroom. Anyone ever had one and not had those common symptoms?

Answer Question
 
Anonymous

Asked by Anonymous at 10:56 PM on Sep. 17, 2010 in Babies (0-12 months)

Answers (5)
  • yes..when i was pregnant i had a bladder infection but no burning, if the antibiotics work then that's probally what it is GL
    josiesmommy00

    Answer by josiesmommy00 at 10:57 PM on Sep. 17, 2010

  • no I haven't
    jessesmama22

    Answer by jessesmama22 at 11:56 PM on Sep. 17, 2010

  • Yes! I did not know my memory was being affected by this either. My husband started watching my actions and counted down the number of times I went to the bathroom. After 12 hours of not going to pee, he knew something was wrong. Then I asked him a few questions that made no sense. We did not know an infection like this can make your mind out of it. I do not remember about 4 days. I was admitted, iv's and catheter. Good luck!
    DianeParog

    Answer by DianeParog at 12:22 AM on Sep. 18, 2010

  • I had a really bad kidney infection once and I didn't have many symptoms other than an annoying pain on the left side by my hip bone and later my back hurt... no signs of a bladder infection until AFTER I started the antibiotics... then it was like I was peeing out razor blades!!
    I had a uterine infection as well after having my son, that was the most pain I have ever been in in my ENTIRE life... 100 times worse than labor... but the symptoms of that I thought I had another kidney infection because my back hurt and I felt sick.
    AmiJanell

    Answer by AmiJanell at 2:15 AM on Sep. 18, 2010

  • when I was pregnant! I didnt have any symptoms at all till I started urinating blood out of nowhere. I was about 11 weeks pregnant. They gave me medication and it went away in a few days as severe as it was!
    Owl_Feather

    Answer by Owl_Feather at 3:22 PM on Sep. 18, 2010

Join CafeMom now to contribute your answer and become part of our community. It's free and takes just a minute.
close Join now to connect to
other members!
Connect with Facebook or Sign Up Using Email

Already Joined? LOG IN