Join the Meeting Place for Moms!
Talk to other moms, share advice, and have fun!

(minimum 6 characters)

1 Bump

Has anyone ever had a bladder infection and not had the painful burning/pulling feeling?

I only had pain in the bladder area all day and night but didn't hurt when I used the bathroom. I also used the bathroom a lot more than normal. I am post partum so doctor talked to me over the phone and guessed it must be a bladder infection or maybe uterine infection. I started taking the antibotics on Wednesday and feel much better. I have had a few UTI's in my day and they have always burned/pulled as u use the bathroom. Anyone ever had one and not had those common symptoms?

Answer Question
 
Anonymous

Asked by Anonymous at 10:57 PM on Sep. 17, 2010 in Health

Answers (8)
  • None of my bladder infections ever hurt when I would go to the bathroom. It was just a constant feeling of having to go, even when I didn't, and only like a drop of pee would come out. They have AZO test strips at drug stores now that you can check at home to see if you have a UTI. I took one one day just for the hell of it, and it came back positive! I had no symptoms at all.
    Ash9724

    Answer by Ash9724 at 11:00 PM on Sep. 17, 2010

  • yes.. Sometimes you do not getting the burning.. It just depends on what kind of infection you have and the bacteria that is causing it. That is why there are so many antibiotics to treat UTI's, bladder, and kidney infections. If it does not go away, have them run a culture before going on another full course of antibiotics.. Also, with the burning (I don't know if you are breastfeeding or not, but pyridium and urised can help with those symptoms when and if you ever get them... But, do NOT take them if you have to give a urine specimen. It will alter the test and cause it to take up to 4 days longer to culture and test.
    Anidawehiwahya

    Answer by Anidawehiwahya at 11:02 PM on Sep. 17, 2010

  • I've had them and not even known it just from peeing in a cup at the doctors.
    Musicmom80

    Answer by Musicmom80 at 11:04 PM on Sep. 17, 2010

  • yes I have had them both ways before. It really depends how bad the infection is. I have had UTI's since I have been a little girl the age of 7. To give you an example, I used Irish Spring Soap by accident and got a UTI with in 24 hours. I had burning and went to the bathroom every 15 minutes, that how bad it was so sick to my stomach. Hope you feel better soon!!
    sta517

    Answer by sta517 at 11:09 PM on Sep. 17, 2010

  • I've had one before, and I didn't have any burning etc. I just had the need to go a lot.
    Natly2007

    Answer by Natly2007 at 11:22 PM on Sep. 17, 2010

  • I had one when I was pregnant. No burning or pain, just had to pee every half hour. And the urine had a different look and odor.
    serioussifL

    Answer by serioussifL at 8:12 AM on Sep. 18, 2010

  • I never had any symptoms at all when I had any sort of urinary infection; they just showed up after a test at the doctor's office. Once when I was pregnant, and once about 10 months pp when I had a physical done.
    preacherskid

    Answer by preacherskid at 1:38 PM on Sep. 18, 2010

  • No. GL.
    sarasmommy777

    Answer by sarasmommy777 at 5:10 PM on Sep. 18, 2010

Join CafeMom now to contribute your answer and become part of our community. It's free and takes just a minute.
close Join now to connect to
other members!
Connect with Facebook or Sign Up Using Email

Already Joined? LOG IN