Join the Meeting Place for Moms!
Talk to other moms, share advice, and have fun!

(minimum 6 characters)

Miscarriage and Pregnancy Loss Support Miscarriage and Pregnancy Loss Support

Still brown blood??!!

Posted by on Aug. 14, 2010 at 4:24 PM
  • 12 Replies

I found out I was pregnant in June.  My pregnancy ended up being a missed miscarriage/ectopic.  I did get the methrotrexate shots in my back for ectopic on July 14.  I bled for what seemed forever, and my levels are below 2, so I know Im not pregnant anymore, but man....I still go to the bathroom and when I wipe its still some brown.  I mean, everytime I go to the bathroom. I dont know if this is normal or not.  Im confused to see when my period starts.  I dont know what to think of it.  I have had a miscarriage before, and it wasnt like this for this long.  Does anyone know anything about this?   Thanks!

by on Aug. 14, 2010 at 4:24 PM
Add your quick reply below:
You must be a member to reply to this post.
Replies (1-10):
racheypoo03
by on Aug. 14, 2010 at 4:30 PM

BUMP!

xoNIKKIox
by on Aug. 14, 2010 at 5:03 PM

I'm so sorry for your loss.

I'm afraid I haven't experienced an ectopic pregnancy. After my miscarriage, my bleeding prettyt much resolved after a week, and I can't recall whether I had any brown spotting--but I know it didn't last for over a month.

Have you spoken with your doctor? I would get in touch--especially if you have no pending follow-up appointments.

Take care--and please keep us posted. hugs




jewels2882
by on Aug. 14, 2010 at 5:15 PM

I wish I could help

echupko
by Group Mod-Elizabeth on Aug. 14, 2010 at 7:18 PM
Wow, I can't believe this is still going on!! That really stinks!! I hope your cycle gets back to normal soon so you can start ttc again!! Good luck!
Posted on CafeMom Mobile
bbmkfo03
by on Aug. 14, 2010 at 9:19 PM

That is a long time to still be spotting. I did not bleed after the metho shot, but remember the week before my doc thought it was a blighted ovum and gave me meds to make me bleed, which I did but only for 4 days. The med didnt work b/c it was ectopic not blighted. So anyway, I only bled after my surgery for a few days and that was it. Nothing since. My metho shot was July 9th. I'd call your doc and see what this could possibly mean. Are you having any cramping or pains?

racheypoo03
by on Aug. 15, 2010 at 1:31 AM

Im not having any cramps or pains.  If I didnt see it on the tissue, I would never even know it was happening.  I got my blood work done LAST Thursday, not this past Thursday and Monday is when they told me that my levels were negative 2, so Im no longer pregnant.  I just dont know what to think of it.  I know if i call my dr, their going to tell me, well....it can take awhile.  Which i know it can, but if im not pregnant and my levels are low, i still dont know why this is happening.  I appreiciate it all ladies....yall are the best!

angeldescending
by on Aug. 15, 2010 at 1:32 AM

BUMP!

bbmkfo03
by on Aug. 15, 2010 at 9:22 AM

I wish I knew the answer. This must be so frustrating for you! *hugs*

mrseckstein
by on Aug. 15, 2010 at 10:07 AM

Oh wow I never had an ectopic pregnancy before this must be very frustrating for you. Gosh. Is there a way you can call your doctor or something like that? He might know. I know after m/c that I bled for a bit less than a week (six days I think) and than I stopped bleeding and things were "back to normal"

Rachelle11503
by on Aug. 15, 2010 at 11:28 AM

I'm sorry, that's probably pretty rough on you. I think it would be a great idea for you to call the doctor and ask if you could at least ask a nurse if it is normal to spot for that long. Hope you stop soon!

Add your quick reply below:
You must be a member to reply to this post.
Join the Meeting Place for Moms!
Talk to other moms, share advice, and have fun!

(minimum 6 characters)