Join the Meeting Place for Moms!
Talk to other moms, share advice, and have fun!

(minimum 6 characters)

Shark Steam Mop NOT Steaming. Help!

Posted by on Apr. 25, 2012 at 4:10 PM
  • 7 Replies

I'm trying to use the Shark Steam Mop and it's not steaming. The green light is on. And I even tried vinegar instead of water like that one post said. It figures it has to happen when DD is FINALLY taking a nap and I have this one chance to clean the floors as I'm prepping for the party this weekend. :/ So, does anyone know how I can get it to work?

by on Apr. 25, 2012 at 4:10 PM
Add your quick reply below:
You must be a member to reply to this post.
Replies (1-7):
johnny4ever
by on Apr. 25, 2012 at 4:34 PM

hmm..I have never had this problem with mine..bump for ya!

SandraJo
by on Apr. 25, 2012 at 5:30 PM
Bump, no idea! I was gonna suggest vinegar but you've already tried that. Maybe let the vinegar soak an hour or 2 to loosen up any buildup?
Posted on CafeMom Mobile
la_bella_vita
by on Apr. 26, 2012 at 12:03 AM

 I've never had that problem, bump

Nutmeg101
by on Apr. 26, 2012 at 8:52 AM
Bump- my friend has this problem right now. She is letting vinegar soak. Waiting to hear more ideas.
Posted on CafeMom Mobile
jsbuck
by Member on Apr. 26, 2012 at 9:37 PM

 Mine did that, too.....it was totally dead, I tried everything.

Bmat
by on Apr. 27, 2012 at 8:56 AM

Have you tried pushing and moving the wires, in case there is a loose wire?

.KanaLee.
by on Apr. 27, 2012 at 9:59 AM
You have to use super hot vinegar... let it sit... use.
Posted on CafeMom Mobile
Add your quick reply below:
You must be a member to reply to this post.
Join the Meeting Place for Moms!
Talk to other moms, share advice, and have fun!

(minimum 6 characters)