Join the Meeting Place for Moms!
Talk to other moms, share advice, and have fun!

(minimum 6 characters)

Its from the ultrasound right? ?

Anonymous
Posted by Anonymous
  • 15 Replies
Not seeking medical advice and i know no one can tell me for sure but i had a vaginal u.s. Wednesday. It went fine. And tonight, friday, there was a glob of blood when i wiped. Not bright red. Not conpletely brown either. Kinda in between.

I know that kind of u.s. can irritate the cervix but 2 days later and im just seeing evidence of it? Still normal?

Im not in pain or cramping so im not TOO worried. Just kinda on alert.
Posted by Anonymous on Jan. 13, 2017 at 10:39 PM
Add your quick reply below:
You must be a member to reply to this post.
Replies (1-10):
Cajunqueenslsg8
by Platinum Member on Jan. 13, 2017 at 10:40 PM
I've never had a vaginal u.s, so I couldn't tell you.
Matka_Kinder
by Tina on Jan. 13, 2017 at 10:40 PM

Probably. The metal thing is pretty big

Anonymous
by Anonymous 2 on Jan. 13, 2017 at 10:44 PM

Are you pregnant? Not all internal u.S. are done only when pregnant. 

If you are pregnant could it be your mucous plug?

Anonymous
by Anonymous 3 on Jan. 13, 2017 at 10:46 PM
Could be. When I had bleeding it was due to low progesterone. So I would personally call just to check with your doctor.
Dardenella
by Ruby Member on Jan. 13, 2017 at 10:49 PM

I would think it would take a little bit for the clot to form and then be sluffed off.  I wouldn't be worried unless there is more nlood or pain or cramping.

If you are in doubt call your doctor.

ElephantShoez
by GoGoWaffleMaker on Jan. 13, 2017 at 10:51 PM
I didn't bleed when I had one. Just keep an eye out for more blood/cramping.
Anonymous
by Anonymous 4 on Jan. 13, 2017 at 10:54 PM
I had them a lot when trying to get pregnant, and then through the first months of pregnancy. I never bled.

I hope it's nothing, but it's better to be safe and call the dr.

I'm sure it's fine.
AmiJanell
by Ruby Member on Jan. 13, 2017 at 10:55 PM

Maybe.  Or maybe you ovulated?... I get spotting when I ovulate. 

Anonymous
by Anonymous 1 - Original Poster on Jan. 13, 2017 at 10:56 PM
Im 10 weeks. It was almost like lube covered toilet paper. But brownish pink. Havent had any since so im hoping its just the u.s.

Quoting Anonymous 2:

Are you pregnant? Not all internal u.S. are done only when pregnant. 

If you are pregnant could it be your mucous plug?

othermom
by Ruby Member on Jan. 13, 2017 at 11:05 PM

I would call the doctor if it happens again. I have never had it happen before so I am not sure

Add your quick reply below:
You must be a member to reply to this post.
Join the Meeting Place for Moms!
Talk to other moms, share advice, and have fun!

(minimum 6 characters)