Join the Meeting Place for Moms!
Talk to other moms, share advice, and have fun!

(minimum 6 characters)

Anyone who uses the Mirena

Posted by on Feb. 20, 2010 at 10:05 PM
  • 8 Replies

I had the mirena put in with my last baby and i'm getting to where i want to get it taken out. I got it put in Oct. 2009, I'm bleeding about 3 weeks out of the month, cramping, nausea..has anyone who's had it had any problems and what are your symptoms?

Mommy to Cazen, Cannon, Cutler, & Creed


Wife to Joey of 6 years..Feb.14,2004

by on Feb. 20, 2010 at 10:05 PM
Add your quick reply below:
You must be a member to reply to this post.
Replies (1-8):
LovelyMother88
by on Feb. 21, 2010 at 12:48 AM

yes, i had the same problem. I bled for a good 2 months straight afterward. It stopped though, i have had it for 2 years now and haven't had any more problems. I actually love it now. I would go ahead and ask your doctor about it just to be safe. Your problem might not be the same as mine was.

jelync
by on Feb. 21, 2010 at 3:50 AM

 I would ask for an ultrasound to check the position. I had mine for about as long as you and has all the symptoms you have and it had partially perforated my uterus. I have a very long uterus and it was difficult to place so it maynot be that.  I have had no lasting damage thou. 

Good Luck 

Moonwhispers
by on Feb. 21, 2010 at 3:53 AM

I had it for about 10 months and I had to get it taken out.  I still had periods the whole time, though they were lighter, then it started screwing up my cycles and moving my periods around.  My period was so bad one month I seriously thought I was miscarrying. I won't ever get it again

DessC
by on Feb. 21, 2010 at 11:02 AM

I had it put in After I had my now 2 year old. It has been in since April of '08 I spotted on a regular basis for 5 months afterward(which if you read directions you would learn that you can spot up to 6 months after insertion) My periods became lighter and now I have one every few months if that. Which is also completely normal. It is not for everyone but I have enjoyed mine and I am looking to get mine removed soon so that my husband and I can try for baby #3

GreenEyePixie
by on Feb. 21, 2010 at 12:16 PM

I just had mine removed. I had to have a partial D&C and hysteroscopy to remove it. I have a large uterus and so it got stuck in the top part of it.

babyfat5
by on Feb. 21, 2010 at 12:58 PM

I had mine put in Feb 2007. The first few months I had random spotting then I had spotting maybe once ever 6mos then once a year now nothing. I've not had any problem with mine, nor did any of my friends who went and got it after me.

dannysgirl77
by on Feb. 21, 2010 at 1:00 PM

I am having those same problems right now. I am on my period for EVER and when I get off, have sex with my hubby I get it back the next day. Man is it cutting into my social life. And I am so tired too...I swear it is from all the blood loss.No cramping for me.

I am to get mine out with in this year. I guess it just gets that way after a while, I had no problems before.


jaymeebrockhaus
by on Feb. 21, 2010 at 1:02 PM

I Got mine put in a yr ago in January.  I have not had any problems @ all.  In fact I haven't had much of a period since then.  Only a little random bleeding every now & then.

Add your quick reply below:
You must be a member to reply to this post.
Join the Meeting Place for Moms!
Talk to other moms, share advice, and have fun!

(minimum 6 characters)