Join the Meeting Place for Moms!
Talk to other moms, share advice, and have fun!

(minimum 6 characters)

TMI/IUD question

Posted by on Jul. 25, 2010 at 6:34 PM
  • 6 Replies
Okay, I had my IUD removed on July 16th and I have still not had a period. My husband and I have been actively trying to have baby #2 but I thought that I would have had a period by now. I have had some brown spotting when I go to the bathroom but that is it. Does anyone think I should worry about it or is it too soon? Thanks in advance for your input. :)
Posted on CafeMom Mobile
by on Jul. 25, 2010 at 6:34 PM
Add your quick reply below:
You must be a member to reply to this post.
Replies (1-6):
bamababe1975
by on Jul. 25, 2010 at 6:49 PM

It's probably just too soon, but if you're concerned, ask your doc. ((HUGS))

momof754
by on Jul. 25, 2010 at 6:54 PM


Quoting bamababe1975:

It's probably just too soon, but if you're concerned, ask your doc. ((HUGS))


nettie79
by on Jul. 25, 2010 at 8:11 PM

 Thanks. I just dont know what to expect without having a period, you know? It's so strange. :)

strongerwtime
by Bronze Member on Jul. 25, 2010 at 9:26 PM

If you are certain it isn't implantation bleeding brought on by pregnancy then I say still, ask the doc about it.

nettie79
by on Jul. 26, 2010 at 7:50 AM
I have no idea what it is. I would love for it to be implantation bleeding but I don't want to hope.
Posted on CafeMom Mobile
IMAMOM2-2KIDS
by on Jul. 26, 2010 at 8:23 AM

 I would give it a good month maybe 2 befor things get back in working order!

Add your quick reply below:
You must be a member to reply to this post.
Join the Meeting Place for Moms!
Talk to other moms, share advice, and have fun!

(minimum 6 characters)