Did anyone have any implantation bleeding or cramping?
  It is a week before my period is to start. I woke up cramping this morning and this afternoon started bleeding. I went through 1 tampon and it has tapered off now  to just a little when I wipe but I am still having period like cramps. I am sure it will be more clear if it is staying or not in the morning. ( it's 9:00pm here)  Anyway I have never had implantation cramping or bleeding. My period was May 28th. I have a normal 28 day cycle. I had sex on the 6th, 9th, 11th and I think the 14th...
 I have had some other strange symptoms but I thought they were more wishful thinking than anything, now I don't know. A few days of sore boobs and the weird one is my bath and body spray has lost all it's good smell...No warm vanilla sugar just chemicals...I hate it. Dh still smells it but I can't .
 I feel so stupid but it's been 8 years. I cannot seem to remember anything about being pregnant.

Add A Comment

Comments:

carni...
Jun. 24, 2008 at 4:22 PM

I had a spot or two with my second, and low back pain early on with my first.  I never had as much so that I could have used a tampon.  I have had mild weird cramping with all three.  But pregnancy is such a soup of hormones.  Sometimes pms is too.  I wanted to be pregnant so bad with my first two that I was in a constant blender.  

I do think that smelling thing is suspicious.  That has always happened to me during pregnancy.

Don't give up hope and keep trying if not!

 

Message Friend Invite

Lb128f
Jun. 24, 2008 at 4:29 PM Hmmm, IDK -- but, GOOD LUCK!!!

Message Friend Invite

rennez
Jun. 24, 2008 at 5:21 PM I had it when I was about 4 weeks along.  It lasted about 1 day, and then it was gone for the rest of my pregnancy.  I was terrified! 

Message Friend Invite

asaffell
Jun. 24, 2008 at 6:08 PM Had both. The cramping made me nervous, but it ended. Spotting is pretty normal. :)

Message Friend Invite

genxm...
Jun. 24, 2008 at 6:53 PM

I've had those symptoms from implantation! 

I'm hoping for you!!!!! 

Message Friend Invite

MamaM...
Jun. 24, 2008 at 7:17 PM I had the spotting with implantatin with dominic. I hope you are, how exciting!

Message Friend Invite

Jenni...
Jun. 25, 2008 at 10:25 AM I think we have shared these stories, but i had horrible cramping when he implanted.  But no bleeding.  It started a week before i was supposed to get my period.  I just kept having that feeling like i was bloated and at any minute, i would have blood gushing.  But it just never came.  only the cramps that lasted 10 days.  

Message Friend Invite

mbmomof3
Jun. 29, 2008 at 3:45 PM

cramping yes, bleeding no.  In fact with #3 the cramping made me think I was going to get AF and when I didn't I took a test and bingo +!!

Message Friend Invite

Forge...
Jun. 30, 2008 at 8:03 AM Well ladies it was my period...No baby this time :(

Message Friend Invite (Original Poster)

Want to leave a comment and join the discussion?

Sign up for CafeMom!

Already a member? Click here to log in

close Join now to connect to
other members!
Connect with Facebook or Sign Up Using Email

Already Joined? LOG IN